Investigating reports of page slowness
Incident Report for LearnZillion
Resolved
The LearnZillion platform is currently functioning normally after increasing server size in response to some reports of page slowness.

We will actively monitor the service to ensure the issue do not recur. Thank you for your patience.
Posted Aug 18, 2021 - 13:00 EDT